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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates the procedure has
only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown (e.g., “copy
file1 ” means type the word copy, then type a space, then type file1).

o On-screen prompts and messages, names of options and text fields, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys from the computer keyboard. For example, “Press Enter ” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics (e.g., “copyfile name” means type the word copy, then type a space, then type
the name of the file).

l The plus sign (+) is used between keyboard keys to indicate that both keys should be
pressed at the same time (e.g., “Press Shift +F1 ” means to press Shift and, while holding
it down, press F1). Always depress the modifier key or keys first (e.g., Shift, Ctrl, Alt, or
Ctrl +Shift), continue to hold it/them down, then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Layout > Interface Ground "
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This instruction means click the Interface Ground command from the Layout tab. An
image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"From the Filemenu, selectOpen Examples" means click the Filemenu and select
Open Examples from the drop-down menu.

l Another alternative is to right-click and select from the shortcut menu. An example of a
typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means select an object, right-
click, and click an option from the shortcut menu that appears.

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. This information can also be obtained by contacting an Ansys
account manager.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps are taken
or what stages the simulation reached, including software files as applicable. This allows more
rapid and effective debugging.

Help Menu

From the Help menu, select Help and choose from the following:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1 to open the chosen help for the active product.

Press F1 while the cursor is pointing at a menu command or while a particular window tab is
open. In this case, the help page associated with the command or open window is displayed
automatically.
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1 - Introduction
Complete theGetting Started with HFSS 3D Layout: Low Pass Filter guide to create a low
pass filter in HFSS 3D Layout, then analyze the design as a planar EM solution. The low pass
filter model consists of three layers (i.e., a ground layer, a dielectric layer, and a signal layer).
The user will need to define the layers, assign a custommaterial to the dielectric layer, draw the
model, define the ports, and set up the solution. After solving the model, the user will review the
S Matrix results, plot the return loss, create a Smith chart, a current density overlay, a far field
display, and animate the results.
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Getting Started with HFSS 3D Layout: Low Pass Filter

HFSS 3D Layout offers several design simulators for HFSS, Planar EM, SIwave, EMI, and
Nexxim. In this topic, learn about the PlanarEm Solution Setup only.

EM Design simulators are the ideal tools for projects that involve full-wave or radiative effects for
multilayered structures. For example, draw the physical layout of a patch antenna or a
millimeter-wave integrated circuit and simulate the electromagnetic properties to display the
following:

l Radiated electric fields
l Basic electromagnetic field quantities
l Characteristic port impedances and propagation constants
l Basic far-field parameters for electromagnetic fields and antennas
l Generalized S-parameters, and S-parameters renormalized to specific port impedances

For more information see the HFSS 3D Layout Simulator in the main help.

Introduction 1-2
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The following topics cover the physical design and EM analysis of a low-pass filter, specifically
the following subtopics:

l How to start Electronics Desktop and explore the HFSS 3D Layout tools
l How to use the HFSS 3D Layout ribbon, menu, and shortcut menu
l Terms and concepts essential to the simulation of an HFSS 3D Layout design
l How to add a custom-defined dielectric material to a design
l How to create a report to display simulation results

Setting General Options
Before inserting an HFSS 3D Layout Design into the project, ensure the Electronics Desktop
options are set appropriately for this exercise.

1. From the Desktop ribbon tab, click General Options.
2. In the tree on the left side of theOptions window, expand theGeneral group and select

the Default Units subgroup.
3. Ensuremm is selected on the Length drop-down menu to use millimeters as the default

length unit.
4. From the Options tree, select the Layout Editor> Snapping subgroup.
5. Under Targets, clear theGrid option and ensure that your other selected options match

the following settings:
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6. From the Options tree, select the Layout Editor> Display subgroup.
7. In theGrid field, enter 10 mm forMajor and 1 mm forMinor, making sure the unit used

for each is millimeter (mm), the default setting.

8. ClickOK to close theOptions window.
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Enabling Legacy View Orientation
The instructions and examples in this guide use the legacy view orientation scheme, rather than
the controls introduced in release 2024 R1. Complete these steps to enable the Legacy View
Orientation and avoid any confusion.
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1. Navigate to Tools >Options > General Options to open the 3D UI Options window.

2. ExpandGeneral and select User Interface.
3. Check the Enable Legacy View Orientation box. When the user has completed the

Getting Started Guide, they should return toOptions window and uncheck the Enable
Legacy View Orientation box.
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4. ClickOK.

Create the Model
From here, continue to the following topics to define the stackup layers (i.e., topology) of the
model, draw the geometry of the filter, and assign the excitation ports.

l Insert Layers
l Draw the Model Geometry
l Assign the Ports

Insert Layers
Complete these steps to insert layers in an HFSS 3D Layout design.
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1. From the Layout tab, click the Layers dialog button to open the Edit Layers window.
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Note:

Alternatively, from Layout, select Layers.
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2. If appropriate, select Laminate from the Stackup area > Type drop-down menu.

Add a Ground Layer to the Grid Control Table

Note:

When adding the first layer to the layers table, the actions of Insert above and Insert
below are identical. Once there are one or more layers in the table, the Insert above
and Insert below options will be inactive until a layer is selected from the Grid
Control Table. After selecting a layer from the table, select the chosen option
depending on where you would like the new layer to appear in the table (i.e., above or
below).

1. Click Layer and select either Insert above or Insert below to open the Add Stackup
Layer window.

2. In the Add Stackup Layer window, do the following:
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a. Enter g1 in the Name field.
b. Select signal from the Type drop-down menu.
c. ClickOK to close the Add Stackup Layer window add the new infinite ground layer to

the Grid Control Table.

Note:

The material copper is automatically assigned to signal layers.

3. If appropriate, add the Negative column to the table. Right-click any column header (e.g.,
Material, Type, or Name) to open the shortcut menu. Then select Negative. The
Negative column will appear in the table.
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4. Check the box in the Negative column.
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Note:

Checking the box in the Negative column identifies the layer as a ground plane
layer. Any object drawn on a negative layer becomes a cutout in the ground layer
(conductor removed). However, no objects can be drawn from the g1 layer for
this model.

5. Ensure the box in the Rough column is not checked.

Note:

If the Rough box is checked, the surface roughness of the conductors is taken
into account when approximating the impedance of the signal traces. However,
surface roughness is ignored for ground layers. Removing the check from the
box in the Rough column prevents a warning to that effect during validation and
solution setup.

Add a Dielectric Layer to the Layer Table
1. Right-click anywhere in the g1 layer and select Insert dielectric above. A new row

appears in the layer table (default Name, Dielectric).

Introduction 1-13

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

2. In the new dielectric row, do the following:
a. In the Name field, replace dielectric with d1.
b. Ensure 1.6mm is entered in the Thickness field.
c. Select Edit from theMaterial drop-down menu to open the Select Definition window.
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3. In the Select Definition window, do the following:
a. Click Add Material to open the View / Edit Material window.
b. In theMaterial Name field, replaceMaterial1 withmy_d1.
c. In the Relative Permittivity Value field, replace 1 with 2.2.
d. ClickOK to save changes, close the View / Edit Material window, and return to the

Select Definition window.
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e. ClickOK to close the Select Definition window.
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Add a Trace (Signal) Layer to the Layer Table
1. Right-click the d1 layer and select Insert signal above. A new row appears in the table.

2. In the new signal row, do the following:
a. In the Name field, replace Signal with t1.
b. Check the box in the Rough column.

Make Changes to All Layers
1. Ensure the Solver option is deselected for all layers. Default solver options are not

overwritten.
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Note:

By default, Select all is chosen in the Layer area drop-down menu, but if the
rows in the layers table are not highlighted, the layers are not actually selected.
To complete step 4, click from the Layer area drop-down menu and choose
Select All again. The rows will immediately be highlighted.

Introduction 1-18

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

Introduction 1-19

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

2. From the Layer area, choose Select all from the drop-down menu.
3. Ensure the "shading" box in the Attributes area (i.e., the middle box) is checked. This

ensures that all objects will be shaded, rather than only outlined (wire frame).
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4. The Edit Layers window should now match the following example.
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Note:

If the stackup is not arranged in the correct hierarchy, rearrange the layers by
clicking+dragging the selection handles in the left column. The t1 layer should
be from the top of the list, followed by the d1 layer in the middle, and the g1 layer
from the bottom.

5. Click Apply and Close to apply the layer definitions and close the Edit Layers window.

Continue to Draw the Model.

Draw the Model
Complete these steps to draw a model in the Layout Editor.

1. From the Layout tab, select t1 from the Active Layer drop-down menu:

2. From the Layout tab, click Draw rectangle.
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Note:

Alternatively, navigate to Draw > Primitive > Rectangle.
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.
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3. Do not click+drag in the Layout Editor. Instead, move the cursor to the X coordinate
field at the bottom of the Layout Editor. Click inside the field, delete the coordinates
already present, and enter 0.

4. Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and press
Enter.

5. Either press Tab until the cursor moves to the Delta X coordinate field or move the cursor
to the field, click inside it, and enter 20.

6. Press Tab to move the cursor to the Delta Y coordinate field, Then type 4.6 in the field and
press Enter to complete the shape.
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Note:

Alternatively, create a rectangle to the exact dimensions required by first creating
a rectangle of any size, in any location, and then modifying its perimeters in the
Properties window. For example, to create the rectangle described previously,
do the following:

a. From the Layout tab, click Draw rectangle.
b. In the Layout Editor, click+drag to draw a rectangle.
c. Select the newly-drawn rectangle to display its perimeters in the Properties

window.
d. In the Properties window, do the following:

i. Ensure the 2 pt Description box is checked.
ii. Enter 0, 0 in the Pt A field.
iii. Enter 20, 4.6 in the Pt B field.
iv. Press Enter to save changes.
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7. Create a second rectangle by doing the following:
a. From the Layout tab, click Draw rectangle.
b. Hover over the lower-right corner of the first rectangle until the cursor turns into a

square when the snap point is found. Then click to snap the first corner of the second
rectangle to that point. This effectively designates the X, Y coordinates for the second
rectangle, as if this position were 20, 0.

c. Click inside the Delta X coordinate field, delete the coordinates already present, and
enter 2.1. Then press Tab.

d. Type -10.5 in the Delta Y coordinate field and press Enter.

8. Create a third rectangle by doing the following:
a. From the Layout tab, click Draw rectangle.
b. Either hover in the Layout Editor and press Tab to move the cursor to the X

coordinate field, or move the cursor to the field and click inside it. Enter 21.05 in the
field, then press Tab.

c. Type 0 in the Y coordinate field, then press Enter.
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d. Either press Tab until the cursor moves to the Delta X coordinate field, or move the
cursor to the field and click inside it. Enter 21.7 in the field, then press Tab.

e. Type 0.7 in the Delta Y coordinate field, then press Enter.

9. Click anywhere else in the Layout Editor to clear the current selection.
10. Zoom In from the space between the right edge of the first rectangle, the top edge of the

second rectangle, and the left edge of the third rectangle, by doing one of the following:
l Spin the mouse wheel to Zoom In/Out.
l Press Ctrl+D.
l From the Layout tab, click Fit All.
l From View, select Fit All.
l From the Layout ribbon, select Zoom > Zoom Area. Then click+drag the mouse to
define an area.
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11. Create a polygon by doing the following:

Note:

During step c, the cursor may become a triangle, since the snapping point
corresponds to the midpoint between the second rectangle's top edge and the
end point of two of the third rectangle's edges.

a. From the Layout tab, click Draw polygon.
b. Hover over the upper-right corner of the first rectangle until the cursor

turns into a square when the snap point is found. Then click (values
displayed in the X, Y coordinate fields will be 20.0, 4.6).

c. Click the upper-left corner of the third rectangle (values displayed in the X,
Y coordinate fields will be 21.05, 0.7)

d. Click the lower-left corner of the third rectangle (values displayed in the X,
Y coordinate text fields will be 21.05, 0.0)

e. Double-click the lower-right corner of the first rectangle (values displayed
in the X, Y coordinate text fields will be 20.0, 0,0)
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12. Press Ctrl+D to fit the drawing in the Layout Editor and clear the current selection.

13. Create duplicate copies of the first two rectangles and the new polygon by doing the
following:
a. Press Ctrl+A to select all the objects.
b. While holding down Ctrl, click the third rectangle to deselect it. The first two rectangles

and the polygon should still be selected.
c. Press Ctrl+C to copy the selected objects.
d. Press Ctrl+V to paste a duplicate set of objects into the Layout Editor. The location of

the pasted objects moves as the mouse is moved.
e. Choose an area in the Layout Editor that does not overlap the original objects. Then

click to drop the new objects. Ensure the new objects remain selected for the next
step.
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14. From the Layout tab, select Flip > About Y (or, from Draw, select Flip Horizontal).

15. Click+drag the selected objects to align with the bottom right corner of the third rectangle.
Once the cursor becomes a square, release-click and the objects will snap into place.

16. Press Ctrl+D to fit the drawing in the Layout Editor and clear the current selection.

17. Create a fourth and final rectangle by doing the following:
a. From the Layout tab, click Draw rectangle.
b. Either hover in the Layout Editor and press Tab to move the cursor to the X

coordinate field, or move the cursor to the field and click inside it. Enter 29.3 in the X
coordinate field, then press Tab.

c. Type 0 in the Y coordinate field, then press Enter.
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d. Either press Tab until the cursor moves to the Delta X coordinate field or move the
cursor to the field and click inside it. Enter 5.3 in the field, then press Tab.

e. Type -10.5 in the Delta Y coordinate field, press Enter.
18. Press Ctrl+A to select all objects.

Note:

It is not mandatory to unite the individual shapes. Where they meet, the solver
treats them as a contiguous object, regardless. However, uniting them produces
a simpler model and eliminates the possibility of accidentally dragging one shape
out of its proper position.

19. From the Layout tab, select Unite to form all the rectangles and polygons into a single
object.

20. The design should match the following figure.

21. Click the object to select it. From the Properties window, replace the text in the Name
field with Filter. Then press Enter to save changes.
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22. Save the design, either by navigating to File > Save or clicking the Save button on any of
the ribbons.

Continue to Assign the Ports.

Create Edge Ports
Complete these steps to add two edge ports to the model.
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1. To create the first port (i.e., Port1), do any of the following:
l Press E to enter Select Edgesmode.
l From the Layout tab, click Select edges > Select Edges.
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l From Edit, click Select Edges.

Note:

Once Select Edges is chosen, the cursor changes: a diagonal line crosses the
tip of the arrow. Refer to the following step.
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2. Click the left side of the leftmost rectangle to select it.

3. To add the first port to the leftmost rectangle, do one of the following:
l From the Layout tab, select Create edge port.

l From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Excitations and select Add Port.
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l From Draw, select Port > Create.
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l Right-click in the Layout Editor and select Port > Create.

Note:

Once a port is created, it appears in the Project Manager > Project Tree >
[active design folder] > Excitations folder.
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4. Create the second port (i.e., Port2) by doing the following:
a. If appropriate, press E to re-enter Select Edgesmode.
b. Click the right edge of the rightmost rectangle to select it.

c. From the Layout tab, select Create edge port.

5. Rename Port 1 by doing either of the following:
l From the Project Manager window, expand the Project Tree > [active design folder]
> Excitations folder. Then right-click Port1, select Rename, and replace Port1 with
p1.
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l From the Project Manager window, expand the Project Tree > [active design folder]
> Excitations folder. Then click Port1. From the Properties window > Port Value field,
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replace Port1 with p1, then press Enter.
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6. Repeat step 5 to rename Port2 to p2.

Continue to Set Up a Planar EM Analysis.
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2 - Set Up Solution and Analyze
This chapter contains the following topics:

l Set Up a Planar EM Analysis
l Set Up Frequency Sweeps
l Explore Disabling Sweeps and Setups
l View the Mesh
l Explore Dynamic Mesh Updates
l Run the Analysis

Set Up a Planar EM Analysis
Solution Setups are listed in the Project Manager window (i.e., expand the Project Tree > 
[active design folder] > Analysis folder). To add a new solution setup to this project using
basic, initial meshing tools, follow these steps.

1. Open the PlanarEMSetup window by doing one of the following:
l From the Simulation ribbon tab, click PlanarEM (Add Planar EM Solution Setup).
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l Right-click Analysis in the Project Manager window and click Add Planar EM
Solution Setup .
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l From HFSS 3D Layout, select Solution Setup > Add Planar EM Solution Setup.

2. From the PlanarEM Setup window > Mesh Selection area, do the following:
l Ensure Fixed Mesh is selected.
l Enter 5 in the Solution Frequency field.
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3. ClickOK to close the PlanarEM Setup window and open the Edit Frequency Sweep
window.

Set Up Solution and Analyze 2-4

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

Continue to Set Up Frequency Sweeps to define the frequency sweep.

Note:

For more information on setting up an HFSS simulation, see Add HFSS Solution
Setup in the product Help.

Set Up Frequency Sweeps
Complete these steps to add, set up, and define either an interpolating or discrete frequency
sweep.
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Note:

If this topic is reached in succession after completing the steps in Set Up a Planar EM
Analysis, the Edit Frequency Sweep window should still be open. If the Edit
Frequency Sweep window is open, skip to step 2.

Add an Interpolating Frequency Sweep
1. From the Project Manager window, expand the Project Tree > [active design folder]

> Analysis folder to view the analysis setup (e.g., PlanarEmSetup1). Then add an
interpolating frequency sweep associated with a Planar EM solution setup by doing one of
the following:

Set Up Solution and Analyze 2-6

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

l Create a solution setup and the Edit Frequency Sweep window automatically appears
(see Set Up a Planar EM Analysis).

l Select the analysis setup (e.g., PlanarEmSetup1). From the Simulation tab, click Sweep
(Set Up Frequency Sweeps) from the ribbon.

l Select the analysis setup (e.g., PlanarEM Setup1). From HFSS 3D Layout, select
Solution Setup > Add Frequency Sweep.
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l Right-click the analysis setup (e.g., PlanarEMSetup1) and select Add Frequency
Sweep.
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2. Ensure Interpolating is selected from the Sweep Type drop-down menu.
3. Select Linear Count from the Distribution drop-down menu in the first row of the

Frequency Sweeps table.
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4. Enter the following parameters in the first row of the Frequency Sweeps table:

l Enter 1.5 (GHz) in the Start column.

l Enter 4.5 (GHz) in the Stop column.

l Enter 201 in the Points field.

Note:

For interpolating sweeps, generating surface current data is only good for the last
adaptive pass of the solution frequency. Surface current data cannot be saved for fixed
mesh analyses.
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Note:

From the Edit Frequency Sweep window, click Preview to display the Sweep Points
window.

Click Close to return to the Edit Frequency Sweep window.

5. ClickOK to add the interpolating sweep and close the Edit Frequency Sweep window.

Add a Discrete Frequency Sweep
1. From the Project Manager window, expand the Project Tree > [active design folder]

> Analysis folder. Then right-click the analysis setup (e.g., PlanarEMSetup1) and select
Add Frequency Sweep to open the Edit Frequency Sweep window.
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2. Select Discrete from the Sweep Type drop-down menu.
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3. Select Linear Count from the Distribution drop-down menu in the first row of the
Frequency Sweeps table.
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4. Enter the following parameters in the first row of the Frequency Sweeps table:

l In the Start column, enter 1.6 (GHz).

l In the Stop column, enter 2.6 (GHz).

l Enter 11 in the Points field.

Note:

For discrete sweeps, generating surface current data enables viewing of currents and
calculate far field effects at multiple frequencies in later post-precessing steps.

5. From theOptions area, check theGenerate surface current box.
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6. ClickOK to finalize the discrete sweep and close the Edit Frequency Sweep window.

Continue to Explore Disabling Sweeps and Setups.

Deactivate/Activate Setups and Frequency Sweeps
Follow these instructions to activate or deactivate setup definitions and frequency sweeps.

Deactivate or Enable a Setup Definition
From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis folder. Then right-click the setup (e.g., PlanarEmSetup1) and select Disable Setup
or Enable Setup. Only one option will be available, depending from the current status of the

Set Up Solution and Analyze 2-16

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

setup (e.g., if the setup is currently deactivated, only Enable Setup will appear in the shortcut
menu).

Set Up Solution and Analyze 2-17

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

Note:

Alternatively, deactivate/activate an analysis setup by either double-clicking the setup
(i.e., located at the Project Managerwindow > Project Tree > [active design folder]
> Analysis folder directory) or right-clicking the setup and selecting Properties to
open the PlanarEMSetup window. Beneath the Setup Name field, uncheck or check
the Enabled box and clickOK to commit the change and close the window.
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When an analysis setup is deactivated, any sweep associated with it has no effect, even if an
associated sweep is enabled.

Deactivate or Activate a Sweep Definition
From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis folder > setup (e.g., PlanarEMSetup1). Then right-click the sweep (e.g., Sweep1)
and select Disable Sweep Analysis or Enable Sweep Analysis. Only one option will be
available, depending from the current status of the setup (e.g., if the sweep is currently
deactivated, only Enable Sweep Analysis will appear in the shortcut menu).
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Note: Alternatively, deactivate/activate a sweep analysis by either double-clicking the
sweep (i.e., located at the Project Managerwindow > Project Tree > [active design
folder] > Analysis folder > setup (e.g., PlanarEMSetup1) directory) or right-clicking
the sweep and select Properties to open the Edit Frequency Sweep window.
Uncheck or check the Enabled box and clickOK to commit the change and close the
window.

Continue to View the Mesh.

View the Mesh
Follow these instructions to view the active design in a number of planar or 3D views.
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Note:

If the Layout Editor is closed or another window is dominant, navigate to HFSS
3D Layout and select Layout Editor.
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If the Layout Editor is still open but no longer dominant, navigate toWindow and
select the active design project from the available options.

From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis folder. Then right-click the setup (e.g., PlanarEmSetup1) and select Pre-Process
Geometry > Display.
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Note:

Alternatively, left-click the setup (e.g., PlanarEmSetup1) and navigate to HFSS
3D Layout > Solution Setup > Pre-Process Geometry > Display.
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A 3D mesh appears on the model in the Layout Editor.

The mesh does not display on a layer that is not visible, and if there are self-intersecting mesh
edges, they will appear highlighted in yellow.

Note:

If this topic has been reached in succession after completing the steps in Explore
Disabling Sweeps and Setups, leave the mesh visible on the model. However, the
mesh can be deactivated by repeating either method described in this topic to view the
mesh. A check mark appears adjacent to Display when the mesh is visible and
disappears when the mesh is hidden.

Continue to Explore Dynamic Mesh Updates.

Choose Manual or Dynamic Mesh Updates
Objects in the Layout Editor can be stretched, compressed, skewed, and otherwise
manipulated by click+dragging the handles that surround the objects, at the edges and
midpoints. By default, an object's mesh is not dynamically updated when the geometry of an
object is altered. The following instructions explain how to refresh the mesh manually or enable
Dynamic Mesh to update the mesh in real time.
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Update the Mesh Manually
From the Project Manager window, expand the Project Tree > [active design folder] >
Analysis folder. Then right-click the setup (e.g., PlanarEmSetup1) and select Pre-
Process Geometry > Refresh.
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Note:

Alternatively, left-click the setup (e.g., PlanarEmSetup1) and navigate to HFSS
3D Layout > Solution Setup > Pre-Process Geometry > Refresh.
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Important:

The consolidation of surfaces into a conformal mesh is skipped for dynamic and
tolerant meshing, including those with light weight geometries. This can lead to
overlapping surfaces in SBR+ simulations. The user should carefully avoid overlapping
surfaces or objects as SBR+ can produce unexpected results.

Enable Dynamic Updates
From the Project Manager window, expand the Project Tree > [active design folder] >
Analysis folder. Then right-click the setup (e.g., PlanarEMSetup1) and select Pre-
Process Geometry > Dynamic Updates.
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Note:

Alternatively, left-click the setup (e.g., PlanarEmSetup1) and navigate to HFSS
3D Layout > Solution Setup > Pre-Process Geometry > Dynamic Updates.

Set Up Solution and Analyze 2-31

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

Reset the Mesh After Using Undo or Redo
Even if Dynamic Updates is enabled, using the Undo or Redo commands to reset the
geometry of the design will disrupt the dynamic update process and the mesh will not
immediately conform to the reset geometry. Refresh, as previously described, to reset the
mesh.

Deactivate Dynamic Updates
Deactivate dynamic updates by repeating either method described in this topic to enable
dynamic updates. A check mark appears adjacent to Dynamic Updates when dynamic updates
are enabled and disappears when dynamic updates is deactivated.

Important:

Before continuing, Save the design.

Experiment with the Layout Editor by activating the mesh, enabling dynamic updates, and
then distorting or even adding new geometry to the model. Use the Select (O) and Handles 
(H) modes to update the cursor, then click+drag to alter the model, as chosen.

After experimenting, deactivate the mesh.

Continue to Run the Analysis.

Run Analyses and Choose Analyses Options
To sequentially run all analysis setups and associated frequency sweeps in the active design, do
one of the following:
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l From the Simulation tab, select Analyze.
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l From HFSS 3D Layout, select Analyze.

l From the Project Manager window, expand the Project Tree > [active design folder].
Then right-click Analysis and select Analyze.
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Note:

Alternatively, run a single sweep by expanding the Project Tree > [active design
folder] > Analysis folder in the Project Manager window. Then right-click the chosen
sweep and select Analyze.

View Progress
From the Electronics Desktop status bar, select Show Progress to expand the Progress
window.
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During analysis, perform the following actions, as appropriate:

l Right-click within the Progress window and select Abort, Clean Stop, or Pause. Clean
Stop completes the computation of the current frequency point, then analysis ends.

l Right-click within the Progress window and select Change Priority > (Highest, Above
Normal, Normal, Below Normal, or Lowest Priority), to change the priority of the
associated solution. Altering the priority can be useful when multitasking, to free up
resources from a computationally intensive application. Conversely, it can prevent less
important programs from excessively slowing down the more intensive application.

Animated Demonstration

Continue to View S Matrix Data.
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3 - Evaluate the Results (Post-processing)
Use the post-processing capabilities of Ansys Electronics Desktop to display the results of a
simulation. Also use the export features to save the analysis data (and an equivalent circuit) in
various industry-standard file formats.

The sections in this topic include:

l View S Matrix Data
l Plot Return Loss
l Plot a User-Defined Graph
l Revise p2 Excitation
l Overlay Current Results
l Modify and Animate Current Overlay
l Create Far Field Plot
l Overlay Far Field Plot on Model Geometry
l Frequency Animated Far Field Plot

View S Matrix Data
Follow these instructions to review the scatter matrix (S Matrix) data at all sweep frequencies or
at a selected frequency, as well as Y and Z matrix data.

1. From the Project Manager window, expand the Project Tree > [active design folder] >
Analysis folder > setup (e.g., PlanarEMSetup1). Then right-click the chosen sweep (e.g.,
Sweep1), and select Results >Matrix Data to open the Solutions window.
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2. From theMatrix Data tab, ensure the S Matrix box is checked.
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3. Check the Display All Frequencies box.
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4. Navigate to the Format sub tab. Then choose the chosen data format from the drop-down
menu (i.e.,Magnitude/Phase(deg), dB/Phase(deg), Real, Imaginary,Magnitude,
Phase(deg), or dB).
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5. To see runtime data pertaining to the analysis, navigate to the Profile tab.
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6. To export data, do the following:
a. Navigate to the Export sub tab and click Export Matrix Data to open an explorer

window.
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b. From the explorer window, do the following:
i. Type a File name, or use the default (e.g., <ProjectName_DesignName>).
ii. Choose the chosen file format from the Save as type drop-down menu (e.g.,

Touchstone (*.sNp), Data Table (spreadsheet) (*.tab), Neutral Model Format
(*.nmf),MATLAB (*.m), or Citifile (*.cit)).

iii. Navigate to the chosen save location. (Default save location is the folder where the
model is saved).

iv. Click Save to save changes, close the explorer window, and return to the Solution
window, or click Cancel to close the explorer window without exporting anything.
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7. To export the matrix data as an equivalent SPICE model, do the following:
a. From the Export sub tab, click Equivalent Circuit Export.

Note: SPICE models require solution data at DC (0Hz) conditions. If there is
no DC frequency value available, a warning dialog box will appear.

b. Click Yes to close the dialog box and open the Equivalent Circuit Export Options
window.
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c. Select the chosen save location, file format, and other equivalent circuit options.
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d. ClickOK to save changes, close the Equivalent Circuit Export Options window, and
return to the Solution window, or click Cancel to close the window without exporting
anything.

8. Close the Solutions window.

Continue to Plot Return Loss.

Plot Return Loss (a Standard Report)
Complete these steps to create a report and plot return loss.

1. Open the Report window by doing one of the following:

l From the Results tab, select Standard Report > 2D.
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l From HFSS 3D Layout, select Results > Create Standard Report > Rectangular Plot.
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l From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Results and select Create Standard Report > Rectangular
Plot.

2. The Report window opens from the Trace tab.
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Note:

The settings described in Step 3 are the default settings in the Report window and it
should not be appropriate to change anything.

3. From the Trace tab, select the following:
a. Choose a sweep from the Solution drop-down menu (e.g., PlanarEMSetup1 :

Sweep1).
b. From the Category list, select S Parameter.
c. From theQuantity list, select S(p1,p1).
d. From the Function list, select dB.

4. Click New Report and the return loss plot opens under the Report window.
5. Close the Report window to view the plot.
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Note:

Return to the plot any time from the Project Manager window (i.e., expand the Project
Tree > [active design folder] > Results folder, and double-click the chosen plot).

Note:

For additional details about formatting the plot, refer to Post Processing and
Generating Reports.

Continue to Plot a Smith Chart.

Plot a Smith Chart
A Smith chart is a convenient means of simultaneously displaying multiple parameters (e.g.,
impedance, reflection coefficients, scattering parameters, constant gain contours, et cetera). It is
a useful graphical aid for electronics engineers working in the radio frequency disciplines.
Complete these steps to create a smith chart.

1. Open the Report window by doing one of the following:
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l From the Results tab, select Standard Report > Smith Chart.
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l From HFSS 3D Layout, select Results > Create Standard Report > Smith Chart.
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l From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Results and select Create Standard Report > Smith Chart.

2. The Report window opens from the Trace tab.
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Note:

The settings described in Step 3 are the default settings in the Report window and it
should not be appropriate to change anything.

3. From the Trace tab, select the following:
a. Choose a sweep from the Solution drop-down menu (e.g., Planar EM Setup 1 :

Sweep 1).
b. From the Category list, select S Parameter.
c. From theQuantity list, select S(p1,p1).
d. From the Function list, select <none>.

4. Click New Report and the return loss plot opens under the Report window.
5. Close the Report window to view the plot.
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Note:

Return to the plot any time from the Project Manager window (i.e., expand the Project
Tree > [active design folder] > Results folder, and double-click the chosen plot).

Continue to Revise An Excitation.

Revise An Excitation
Before creating an overlay of the current results and animating it, alter the edge port definition for
port p2. The default configuration applies an identical 1 volt magnitude excitation at 0 degrees
phase angle to both of the added ports (p1 and p2). Now set the p2 excitation to 0 volts,
essentially making p1 the input of the low pass filter and p2 the output for the purpose of the
overlay.

To revise the p2 excitation:

1. From the Project Manager window, expand the Project Tree > [active design folder]
> Excitations folder. Then double-click p2 to open the Edge Port Definition window.
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The Edge Port Definition window provides the following configurable settings:
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Port Definition area:

l Port Name specify the port being defined

l Terminal the name of the terminal (automatic, unfillable field)

l Reference the Port Solver (Reference) used by the port

l Calibration Zo the impedance (equivalent to the Full Port Impedance of the port (in
Ohms))

PlanarEM area

l Type of port (automatic, unfillable field)

l Ignore Reference check to ignore the Port Solver (Reference)

l Use Port Solver select to calculate the characteristic impedance and propagation
constant of the port. The gap source is automatically calibrated for greater accuracy

l Use Default select if the default setting (expressed in 0hms) is used, instead of the Port
Solver (Reference)

HFSS area

l Type of port (automatic, unfillable field)

Post Processing Settings area

l Magnitude expressed in Volts (V)

l Phase expressed in degrees (deg)

l Renormalize Impedance check to use, expressed in ohms

Note:

Even if Renormalize Impedance is checked, renormalization is ignored if it is set to
zero. De-embedding is still honored. However, a warning message appears forall ports
with a zero post-processing renormalization impedance: Zero impedance on port
'<PortName>' is ignored; renormalization is skipped for this port.

l Deembed Distance (PEM Only) check to use, expressed in millimeters (mm)

l Deembed Gap Port Inductance check to specify the inductance of the port, which is
calculated and cached as part of the solution data for subsequent use. During post-
processing a list of the ports to deembed is used to calibrate the network data.
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Note:

For more information, refer to Deembedding.

2. From the Post Processing Settings area, enter the following:
a. In theMagnitude field, enter 0V.
b. In the Phase field, enter 0deg.
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3. ClickOK to save changes and close the Edge Port Definition window. Repeat for
additional ports.
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Note: Alternatively, use the Port Excitations window to make changes to
multiple ports within the same window. To access the Port Excitations window,
from the Project Manager window, expand the Project Tree and [active
design folder]. Then right-click Excitations and select Port Excitations to
open the Port Excitations window.

Evaluate the Results (Post-processing) 3-29

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

Continue to Overlay Current Results.

Use Field Overlays
Complete these steps to overlay the magnitude of the surface current results from the trace layer
of the low pass filter.
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1. From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Field Overlays and select Plot PEM Fields >Mag_SurfaceJ to
open the Create Field Plot window.
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Note:

The only Solution available is PlanarEMSetup1:Sweep2, since only the
discrete sweep type has the option to output currents.

2. From the Intrinsic Variables area, select 2.1GHz from the Freq (frequency) drop-down
menu. 2.1 GHzmost closely corresponds to the point of minimum return loss from the S
Parameter plot.
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3. Under the Nets and Layers tab, check the t1 box.
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4. Click Done to save changes and close the Create Field Plot window.
5. If appropriate, refocus from the overlay. From the Project Manager window, expand the

Project Tree > [active design folder] > Field Overlays folder. Then double-click J Surf.

Animated Demonstration

Continue to Modify and Animated Current Overlay.

Evaluate the Results (Post-processing) 3-35

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

Modify and Animate the Current Overlay
Complete these steps to modify a plot legend (colors and scale) and animate the current plot
(i.e., J Surf):

1. From the Layout tab, double-click in the current plot overlay legend to open the (J Surf)
plot settings window.
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2. From the Color map tab, select Temperature from the Spectrum drop-down menu.
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3. Select the Scale tab and do the following:
a. In the Num. Division field, enter 21.
b. Select Use Limits.
c. In theMin field, enter 0.1.
d. In theMax field, enter 26.0.
e. Select Log (to produce a logarithmic scale).
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4. Close the plot settings window.
5. From the Project Manager window, expand the Project Tree > [active design folder]

> Field Overlays > J Surf. Then right-clickMag_SurfaceJ1 and click Animate to open
the Create Animation Setup window.
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6. From the Swept Variables tab, do the following:
a. Ensure Single variable and Phase are selected from the drop-down menus.
b. In the Stop field, enter 350deg.
c. In the Steps field, enter 35.

Evaluate the Results (Post-processing) 3-42

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

Note:

These settings result in an animation with 10° (35deg / 350deg) phase
increments. A 360° phase (360deg) would be identical to the 0° phase, resulting
in a redundant animation frame, and is thus omitted.

7. ClickOK to close the Create Animation Setup window to open an animation control
panel and start the animation in the Layout Editor.
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8. Use the animation controls to reverse, stop, and change the speed of the animation,
among other settings.

9. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor
controls.
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10. From the animation control panel, click Close to end the animation.
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Continue to Create Far Field Plot.

Create Far Field Plot
Far fields are usually not of interest when designing a filter, but the procedure is shown here for
reference. Current outputs are required as the basis of far field computations. To save results,
and current and field results available to plot, satisfy one of the following conditions, then
complete these steps.

l Run a discrete frequency sweep, as follows:
l From theOptions area, check theGenerate surface current box.
l Specify multiple discrete frequency points and have the current and field results
bavailable for all specified frequencies.

l Define the frequency at which the far field results are viewed.
l Animate the resulting plot. The animation should progress from one frequency to the
next.

l Set up a Planar EM analysis, as follows:
a. From the Planar EM Setup window >Mesh Selection area, choose Standard

Adaptive or Advanced Adaptive.
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b. Check the Save currents for last adaptive pass box. The current and field results
are only available for the last adaptive pass of the specified solution frequency.
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c. ClickOK to close the PlanarEMSetup1 window and save changes.

Plot Far Field Results
Complete these steps to set up a far field infinite sphere and plot the results.

1. From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Radiation and select Insert Far Field Setup... > Infinite
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Sphere..

The Infinite Sphere Setup window opens.
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2. Make no changes to the default configuration and clickOK to close the Infinite Sphere
window and add the far field setup to the design.
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3. From the Results ribbon, select Far Fields Report > 3D Polar.

The Report window opens.
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Note:

Alternatively, open the Report window by doing one of the following:

l

From the Project Manager window, expand the Project Tree and [active
design folder]. Then right-click Results and select Create Far Fields Report >
3D Polar Plot.
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l

From HFSS 3D Layout, select Results > Create Far Fields Report > 3D Polar
Plot.
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Note:

In Step 4, the Solution andGeometry drop-down menus pre-select the only available
choices that provide far field results (i.e., PlanarEMSetup1: Sweep2 is selected in the
Solution drop-down menu, and Infinite Sphere 1 is selected in theGeometry drop-
down menu) and the lists in the Trace tab pre-select the chosen choices (i.e., Far Field
is selected in the Category list, Etotal is selected in theQuantity list, and <none> is
selected in the Function list).

4. Select the Families tab. From the Families tab > Freq row, click the [...] button in the Edit
column.

Evaluate the Results (Post-processing) 3-56

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Low Pass Filter

A value list opens.

5. Select 2.1GHz, which corresponds closest to the point of minimum return loss. Then click
outside of the value list to close it.

6. From the Report window, click New Report and the far field plot opens under the Report
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window. Close the Report window to access the plot.
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7. Close the Report window to view the plot.
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Note:

Alternatively, open the Report window by doing one of the following:

l

From the Project Manager window, expand the Project Tree and [active
design folder]. Then right-click Results and select Create Far Fields
Report > 3D Polar Plot.
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l

From HFSS 3D Layout, select Results > Create Far Fields Report >
3D Polar Plot.
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8. From the Layout Editor, Zoom, Rotate, or Pan the far field plot using the standard
Layout Editor controls.

Continue to Overlay Far Field Plot on Model Geometry.

Overlay a Far Field Plot on Model Geometry
To better see how the far field pattern relates to the low pass filter geometry, follow these steps
to overlay the pattern on the model in the Layout Editor.
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1. To refocus from the field overlay in the Layout Editor, expand the Project Manager
window > Project Tree > [active design folder] > Field Overlays. Then double-click J
Surf.

2. Expand J Surf, then right-clickMag_SurfaceJ1 and select Plot Visibility to remove the
check and the overlay from the design shown in the Layout Editor.
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The J Surf legend and color contour map are no longer visibile. Making the surface current
results invisible avoids confusion about the values and units of the far field plot overlay.
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3. From the Project Manager window, expand the Project Tree > [active design folder]
> Results. Then right-click Far Field Plot 1 and select Show In Modeler Window.
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4. From the Layout Editor, Zoom, Rotate, or Pan using the standard Layout Editor
controls.
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Continue to Frequency Animated Far Field Plot.

Animate a Field Plot
Complete these steps to animate the far field plot to see how fields vary with frequency.
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Getting Started with HFSS 3D Layout: Low Pass Filter

1. FromWindow, select Far Field Plot 1 to refocus from the far field plot in the View tab.

2. Right-click in the Far Field Plot 1 and select View > Animate to open the Select
Animation window.
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3. Click Edit to open the Create Animation Setup window.

4. Ensure the settings in the Create Animation Setup window match the following example.
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Getting Started with HFSS 3D Layout: Low Pass Filter

5. ClickOK to close the Create Animation Setup window and start the animation in the
View tab. Simultaneously, an animation control panel opens.

6. Use the animation controls to Reverse, Stop, and change the speed of the animation, as
chosen.

style="border:1px solid #000000"

7. If appropriate, click+drag the frequency legend to a more desirable location.
8. From the animation control panel, click Close to end the animation.
9. Save the design, either by navigating to File > Save or clicking the Save button on any of

the ribbons.
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Getting Started with HFSS 3D Layout: Low Pass Filter

Congratulations, the HFSS 3D Layout low pass filter getting started guide is complete.

Evaluate the Results (Post-processing) 3-73

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.


	Table of Contents
	1 - Introduction
	Setting General Options
	Enabling Legacy View Orientation
	Create the Model
	Insert Layers
	Add a Ground Layer to the Grid Control Table
	Add a Dielectric Layer to the Layer Table
	Add a Trace (Signal) Layer to the Layer Table
	Make Changes to All Layers

	Draw the Model
	Create Edge Ports

	2 - Set Up Solution and Analyze
	Set Up a Planar EM Analysis
	Set Up Frequency Sweeps
	Add an Interpolating Frequency Sweep
	Add a Discrete Frequency Sweep

	Deactivate/Activate Setups and Frequency Sweeps
	Deactivate or Enable a Setup Definition
	Deactivate or Activate a Sweep Definition

	View the Mesh
	Choose Manual or Dynamic Mesh Updates
	Update the Mesh Manually
	Enable Dynamic Updates
	Reset the Mesh After Using Undo or Redo
	Deactivate Dynamic Updates

	Run Analyses and Choose Analyses Options
	View Progress


	3 - Evaluate the Results (Post-processing)
	View S Matrix Data
	Plot Return Loss (a Standard Report)
	Plot a Smith Chart
	Revise An Excitation
	Use Field Overlays
	Modify and Animate the Current Overlay
	Create Far Field Plot
	Plot Far Field Results

	Overlay a Far Field Plot on Model Geometry
	Animate a Field Plot


